How to Install Code::Blocks IDE 16.01 in Ubuntu 16.04

Code Blocks IDE

Code::Blocks is an open-source, cross-platform, full-featured C, C++, and Fortran IDE designed to be very extensible and fully configurable.

While Ubuntu provides the old Code::Blocks 13.12 release in its universe repository, this tutorial shows you how to install the latest stable Code::Blocks 16.01 using PPA.

1. Add Code::Blocks Stable PPA, so you can receive future software updates along with system updates using Software Updater.

Open terminal from Unity Dash or by pressing Ctrl+Alt+T combination key. When it opens, paste the command below and hit run:

sudo add-apt-repository ppa:damien-moore/codeblocks-stable

Type in password (no visual feedback) when it asks and hit Enter to add PPA.

2. If you have Synaptic Package Manager, you can now launch it, search for and install the IDE after clicking Refresh.

Or just run the commands below one by one to do update and install the software:

sudo apt update

sudo apt install codeblocks

You may need to log out and log in back after installation to make it available in Unity Dash/App Launcher.

3. (Optional) To remove Code::Blocks IDE, use Synaptic Package Manager or run the command below in terminal:

sudo apt remove codeblocks && sudo apt autoremove

And the PPA can be removed via Software & Updates utility -> Other Software tab.

By Ji m

I'm a freelance blogger who started using Ubuntu in 2007 and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please comment to remind me outdated tutorial! And, notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me via Buy me a coffee:


  1. Compiler for what ? On ubuntu you can install compiler directly by apt-get, on windows you have mingw port on sourceforge for example. BTW maybe codeblocks have version with compiler, default no.

  2. Thanks a million it really works .
    Now if I can just get Unity to show all applications in the dash.

  3. If you don’t run sudo apt update before opening synaptic, you won’t be able to install the latest version. So either you use synaptic or the terminal, the update is necessary before trying to install

  4. how to resolve the following errors

    The following packages have unmet dependencies:
    codeblocks : Depends: libcodeblocks0 (= 16.01svn10922-1) but it is not going to be installed
    Depends: libwxbase3.0-0 (>= 3.0.2) but it is not installable
    Depends: libwxgtk3.0-0 (>= 3.0.2) but it is not installable
    E: Unable to correct problems, you have held broken packages.

Comments are closed.

Exit mobile version