The GetDeb repository now is maintaining the latest FileZilla client to make it easy to install and upgrade FileZilla in Ubuntu 16.04.
FileZilla FTP Client is available in Ubuntu universe repositories, but Canonical does not provide updates for the application. You have to manually install / upgrade the client as a new version is released.
While the official Linux binary is not well integrated with Ubuntu, the
GetDeb repository now builds FileZilla for Ubuntu 16.04, so far it’s version 3.19.0.
How to install the latest FileZilla in Ubuntu 16.04:
1. Add GetDeb repository.
For Ubuntu 16.04 and derivatives, open terminal and paste (Ctrl+Shift+V) the command below and hit run:
sudo sh -c 'echo "deb http://archive.getdeb.net/ubuntu xenial-getdeb apps" >> /etc/apt/sources.list.d/getdeb.list'
Type in your password when it asks (no visual feedback) and hit enter.
To make Ubuntu trust the packages from that repository, install the key:
wget -q -O - http://archive.getdeb.net/getdeb-archive.key | sudo apt-key add -
2. Install / Upgrade FileZilla Client.
If you have a previous release installed, you can now upgrade it by launching Software Updater:
Or you may run the commands below one by one in terminal to install / upgrade the FTP client:
sudo apt update sudo apt install filezilla
I followed your instructions, and now when I try to start filezilla this is what happens:
filezilla: symbol lookup error: filezilla: undefined symbol: _ZN2fz18replace_substringsERNSt7__cxx1112basic_stringIwSt11char_traitsIwESaIwEEERKS5_S8_
Any idea what to do about it, or how to go back to the official ubuntu version?
return this error mint 17.3
The following packages have unmet dependencies:
filezilla : Depends: libdbus-1-3 (>= 1.9.14) but 1.6.18-0ubuntu4.3 is to be installed
Depends: libfilezilla0 but it is not going to be installed
Depends: libgnutls30 (>= 3.4.2) but it is not installable
Depends: libnettle6 but it is not installable
Depends: libpugixml1v5 (>= 1.7) but it is not installable
Depends: libstdc++6 (>= 5.2) but 4.8.4-2ubuntu1~14.04.3 is to be installed
Depends: libwxbase3.0-0v5 (>= 3.0.2+dfsg) but it is not installable
Depends: libwxgtk3.0-0v5 (>= 3.0.2+dfsg) but it is not installable
E: Unable to correct problems, you have held broken packages.
Linux Mint 17.3 is Ubuntu 14.04 based, and Getdeb repository does not offer Filezilla for 14.04.
Try the command below to fix broken packages:
Then disable PPAs and third-party repositories via Software Sources (I’ve not been using Mint for a period of time, it may be called something else) utility.
Finally reinstall the original version of FileZilla from Mint repository:
Tried this on Linux Mint 18
Now FileZilla won’t start
Worked for me just fine…
Comments are closed.