digiKam 4.2.0 Released, Install it in Ubuntu 14.04

Last updated: April 24, 2024

digiKam, open-source image organizer and tag editor, has reached version 4.2.0 one days ago on August 5th. The developer team announced in the website:

Dear digiKam fans and users,

The digiKam Team is proud to announce the release of digiKam Software Collection 4.2.0. This release includes important features to simplify photograph workflow :

These features have been introduced by Mohamed Anwer Google Summer of Code project which have been completed in time and judged ready for production.

As usual, we have worked hard to close your reported issues since the previous stable release 4.1.0. A list of the issues closed in digiKam 4.2.0 is available through the KDE Bugtracking System.

digiKam 4.2 loading

Install / Upgrade to digiKam 4.2 in Ubuntu 14.04:

Besides building from the source tarball, you can upgrade digiKam through this third-party PPA.

Press Ctrl+Alt+T on keyboard to open the terminal. When it opens, run the commands below one by one to add the PPA and install or upgrade digiKam in Ubuntu 14.04:

sudo add-apt-repository ppa:philip5/extra

sudo apt-get update

sudo apt-get install digikam

If you’ve upgrade to KDE 4.14 through Kubuntu Backports PPA, run below commands instead to avoid dependencies issue.

sudo add-apt-repository ppa:philip5/kubuntu-backports

sudo apt-get update

sudo apt-get install digikam

That’s it. Enjoy!


I'm a freelance blogger who started using Ubuntu in 2007 and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please comment to let me know if the tutorial is outdated! And, notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me via ubuntuhandbook1@gmail.com Buy me a coffee: https://ko-fi.com/ubuntuhandbook1

11 responses to digiKam 4.2.0 Released, Install it in Ubuntu 14.04

  1. Hy,

    I have done the installing process but i got this error:

    dpkg: error processing archive /var/cache/apt/archives/digikam_4%3a4.2.0-trusty~ppa1_amd64.deb (–unpack):
    trying to overwrite ‘/usr/share/kde4/config.kcfg/photolayoutseditor.kcfg’, which is also in package kipi-plugins 4:3.5.0-0ubuntu10
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Processing triggers for hicolor-icon-theme (0.13-1) …
    Processing triggers for man-db ( …
    Processing triggers for menu (2.1.46ubuntu1) …
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    • 1. Try:

      sudo apt-get -f install

      If step 1 does not work, open file browser with root (gksudo nautilus), go into computer/var/lib/dpkg/info and delete everything that had the name (digikam) and you may also have to go into /var/cache/apt/archives and do the same thing.

  2. Sorry, but upgrade doesn’t work, because kipi-plugins couldn’t be installed. This package couldn’t be installed because libkgeomap1 couldn’t be installed and so on.
    The is the reason why I sometimes hate the dependecies. But its not its fault its because of the developers which are unable to use it the right way.

  3. The problem with updating to digikam 4.2 with my packages for (k)ubuntu 14.04 usually have to do with conflicting versions of KDE and/or Plasma. Especially if you installed Plasma 5 from a 3rd party source that Digikam wasn’t build to use. The problem most people have had in those cases is related to conflicts with versions of the packages libmarblewidget18 and libastro1. Check if that’s your case too and solve that package conflict…

    • Dear all,
      I also ran into the dependancy problem when trying to upgrade from digikam 4.0 (KDE 14.4) to digikam 4.2.
      As software sources I only use kubuntu packports (from which I got digikam 4.0) and the ppa from Philip (https://launchpad.net/~philip5/+archive/ubuntu/extra). Dependency problems were centered around libkgeomap1, libmarblewidget18 and libastro1. Even after removing digikam 4.0 I was not able to install digikam 4.2.
      I have no idea how to remove the depedency problems. Any suggestions are greatly appreciated.



  4. Tip on fixing the problem, with problem overwrite photolayoutseditor.kcfg, that worked for me.

    apt-get remove kipi-plugins

    This will also remowe all old digikam packages (digikam, digikam-dbg and showfoto).

    After this is done, run a new digikam install

    apt-get install digikam

  5. Any body could helpme with the Libkgeomap2 .. I tried to install it manual with synaptic and got no results..

    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    No se pudieron instalar algunos paquetes. Esto puede significar que
    usted pidió una situación imposible o, si está usando la distribución
    inestable, que algunos paquetes necesarios no han sido creados o han
    sido movidos fuera de Incoming.
    La siguiente información puede ayudar a resolver la situación:

    Los siguientes paquetes tienen dependencias incumplidas:
    digikam : Depende: libkgeomap2 (>= 1.0~digikam4.8.0) pero no va a instalarse
    Recomienda: kipi-plugins pero no va a instalarse