Archives For Fix Miro 6 dependencies

Miro
The latest Miro 6 is not available from the PPA repository for Ubuntu 13.04 Raring, and Linux Mint 15 users. It can be fixed by installing from the old repository as well as the depencenies.
To do so, press Ctrl+Alt+T to open terminal and follow the below steps:

1.) Miro 6 depends on libtorrent-rasterbar6 while the default is libtorrent-rasterbar7 in Ubuntu 13.04. So first download and install this package from the 12.10 Quantal’s repository:

Check 32-bit or 64-bit by Unity Dash -> search and open Details

1. For 32-bit, run this command to download the package:

wget https://launchpad.net/ubuntu/+archive/primary/+files/libtorrent-rasterbar6_0.16.3-0ubuntu1_i386.deb

2. For 64-bit, run command to download the package:

wget https://launchpad.net/ubuntu/+archive/primary/+files/libtorrent-rasterbar6_0.16.3-0ubuntu1_amd64.deb

3. For both 32 and 64-bit, install the package and fix any dependency problem with 2 commands:

sudo dpkg -i libtorrent-rasterbar6_0.16.3-0ubuntu1_*.deb
sudo apt-get -f install

2.) Now add the Miro PPA repository.

1. Run command in terminal to add the ppa:

sudo add-apt-repository ppa:pcf/miro-releases

2. Then go to Unity Dash -> Software & Updates -> Other Software tab, scroll down and highlight the line said “http://ppa.launchpad.net/pcf/miro-releases/ubuntu raring main”. Then click on edit, change raring to precise after Destribution.

miro-repository

3.) Finally install Miro 6

Finally you can install Miro 6 by Synaptic Package Manager, or run this command in terminal:

sudo apt-get update; sudo apt-get install miro

Enjoy!

UPDATE: Ubuntu 14.04 users, please read this post to install Miro 6