Foliate – A Simple & Modern New GTK eBook Viewer

July 13, 2019

Foliate is an open-source GTK eBook viewer built with GJS and Epub.js. It offers a simple and modern user interface, and features:

  • View EPUB files in two-page view or scrolled view
  • Customize font, line-spacing, margins, and brightness
  • Light, sepia, dark, and invert mode, or add your own custom themes
  • Reading progress slider with chapter marks
  • Bookmarks and annotations
  • Quick dictionary lookup with Wiktionary, Wikipedia, and dictd, or translate text with Google Translate
  • Touchpad gestures—use two-finger swipe to turn the page
  • Basic text-to-speech support with eSpeak NG and Festival

To install foliate ebook reader in Ubuntu 18.04 and higher:

The software offers Ubuntu .deb package, com.github.johnfactotum.foliate_1.4.0_all.deb at the moment, which is available to download at the release page:

Foliate releases (.deb)

Grab the package, then either double-click to install it, or open terminal (Ctrl+Alt+T) and run command:

sudo dpkg -i ~/Downloads/com.github.johnfactotum.foliate_*.deb

Once installed, launch the software from your system application menu and enjoy!

(Optional) To remove the software, simply run command in terminal:

sudo apt remove --auto-remove foliate

For those who prefer the Flatpak package, Foliate is also available in Flathub repository.

I'm a freelance blogger who started using Ubuntu 5+ years ago and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me on Google Plus or email to [email protected]

3 responses to Foliate – A Simple & Modern New GTK eBook Viewer

  1. Hi

    Get this message when I try to run the programme.

    >com.github.johnfactotum.Foliate:24233): Gjs-WARNING **: 20:04:27.290: JS ERROR: Error: Requiring WebKit2, version none: Typelib file for namespace ‘WebKit2’ (any version) not found
    @resource:///com/github/johnfactotum/Foliate/js/main.js:31:7
    @./com.github.johnfactotum.Foliate:9:1

    Script ./com.github.johnfactotum.Foliate threw an exception

    Trying to uninstall also gives me an error

    >E: Unable to locate package foliate

  2. Hi,

    The dependency error has been fixed in the 1.5.1 package.

    To uninstall, you should run:
    sudo dpkg -r com.github.johnfactotum.foliate

    • Hi,
      I m still getting the error

      Selecting previously unselected package com.github.johnfactotum.foliate.
      (Reading database … 187247 files and directories currently installed.)
      Preparing to unpack …/com.github.johnfactotum.foliate_1.5.1_all.deb …
      Unpacking com.github.johnfactotum.foliate (1.5.1) …
      dpkg: dependency problems prevent configuration of com.github.johnfactotum.foliate:
      com.github.johnfactotum.foliate depends on gjs (>= 1.52); however:
      Package gjs is not installed.

      dpkg: error processing package com.github.johnfactotum.foliate (–install):
      dependency problems – leaving unconfigured
      Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) …
      Processing triggers for desktop-file-utils (0.22-1ubuntu5.2) …
      Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20180209-0ubuntu1) …
      Rebuilding /usr/share/applications/bamf-2.index…
      Processing triggers for mime-support (3.59ubuntu1) …
      Processing triggers for libglib2.0-0:amd64 (2.48.2-0ubuntu4.1) …
      Processing triggers for hicolor-icon-theme (0.15-0ubuntu1.1) …
      Errors were encountered while processing:
      com.github.johnfactotum.foliate