How to Install VLC 2.2.5 in Ubuntu 16.04, 14.04

May 12, 2017

VLC media player 2.2.5 was released recently with a great number of improvements. Here’s how to install it in Ubuntu 14.04, and Ubuntu 16.04.

It has been almost one year since the last VLC 2.2.4 was released on June 2016. VLC 2.2.5 features:

  • Fix green line rendering on Windows with AMD drivers
  • Fix mp3 playback regression on macOS and 64bit Windows leading to distortion for some media
  • Fix screenshots size
  • Improved lua scripts for various websites
  • Various security improvements in demuxers and decoders
  • Security hardening for DLL hijacking environments
  • Fix scrolling sensitivity on Sierra
  • Fix screen recording on Windows
  • See the changelog for details.

VLC 2.2.5

How to Install VLC 2.2.5 in Ubuntu / Linux Mint:

Besides building VLC 2.2.5 from the source tarball, Ubuntu 14.04, 16.04, and Linux mint 18 users can install it from the unofficial PPA.

1. Open terminal via Ctrl+Alt+T or by searching “Terminal” from start menu. When it opens, run command to add PPA:

sudo add-apt-repository ppa:jonathonf/vlc

Type in your password (no visual feedback due to security reason) when prompts and hit Enter.

VLC 2.2.5 PPA

2. (IMPORTANT) Remove old VLC version to avoid a package conflict:

sudo apt remove vlc vlc-nox

3. Finally run commands in terminal to check updates and install VLC 2.2.5:

sudo apt update && sudo apt install vlc

How to Restore:

To restore VLC media player to the stock version in your main Ubuntu repository, run command to purge the PPA:

sudo apt install ppa-purge && sudo ppa-purge ppa:jonathonf/vlc

I'm a freelance blogger who started using Ubuntu 5+ years ago and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me on Google Plus or email to ubuntuhandbook1@gmail.com

16 responses to How to Install VLC 2.2.5 in Ubuntu 16.04, 14.04

  1. Great tip, thanks!

  2. Bhaskar Chawla May 17, 2017 at 10:05 am

    I did this but I can’t install the libde265 plugin after installing this. It has unmet dependencies (libvlccore7).

  3. $ sudo apt-get install vlc

    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    vlc : Depends: libgles1-mesa (>= 7.8.1) but it is not going to be installed or
    libgles1
    Depends: libgles2-mesa (>= 7.8.1) but it is not going to be installed or
    libgles2
    E: Unable to correct problems, you have held broken packages.

  4. $ sudo apt-get install vlc

    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    vlc : Depends: libgles1-mesa (>= 7.8.1) but it is not going to be installed or
    libgles1
    Depends: libgles2-mesa (>= 7.8.1) but it is not going to be installed or
    libgles2
    E: Unable to correct problems, you have held broken packages.

  5. The same error, VLC gone…. help

    • It works on ubuntu 16.04 in my case. Did you guys on Ubuntu 14.04 and installed the updated X stack from the point release?

  6. Same error vlc : Depends: libgles1-mesa (>= 7.8.1) but it is not going to be installed or
    libgles1

    • To solve

      sudo apt-get update
      sudo apt-get install ppa-purge
      sudo ppa-purge ppa:videolan/stable-daily
      sudo apt-get update
      sudo apt-get install vlc

  7. Hi sir, could you please help me to install Vmware on ubuntu 16.04 LTS, or please mention the link of site as well. thanks in advance…

  8. Many thanks from Germany. All other sites I read could NOT solve this buggy problem!

  9. ** Thanks for all for the Suggestions **

    I am here to provide you sure shot method to install vlc player on Ubuntu 16.04 LTS
    as on 04 Nov 2017 (GMT)

    sudo apt-get update (Updates the repository on ubuntu machine)
    sudo apt-get upgrade (Upgrade helps to upgrade old library to latest stable release)
    sudo apt-get dist-upgrade (same as above)
    sudo apt-get autoremove (Autor emove helps to removes obsolete packages)
    sudo apt-get autoclean (Cleans packages that are not more required after getting replaced by new version).

    Go to >> software & updates (short cut — Press Windows key and type there)

    Select options are as below :
    Ubutnu Software : Select options if not
    – Canonical-supported free and open-source software (main)
    – Canonical-maintained free and open-source software (universe)
    Download from : Main Server

    Again
    sudo apt-get update
    sudo apt-get update
    sudo apt-get install vlc

  10. Thank you Ji m, it worked like a charm on Mint 17.3

  11. Reading package lists… Error!
    E: Encountered a section with no Package: header
    E: Problem with MergeList /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_trusty_main_i18n_Translation-en
    E: The package lists or status file could not be parsed or opened.
    don@don-TravelMate-5760:~$ sudo apt remove vlc vlc-nox
    Reading package lists… Error!
    E: Encountered a section with no Package: header
    E: Problem with MergeList /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_trusty_main_i18n_Translation-en
    E: The package lists or status file could not be parsed or opened.
    don@don-TravelMate-5760:~$ sudo apt install vlc
    Reading package lists… Error!
    E: Encountered a section with no Package: header
    E: Problem with MergeList /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_trusty_main_i18n_Translation-en
    E: The package lists or status file could not be parsed or opened.
    don@don-TravelMate-5760:~$

    i am facing these problems what can i do pliz

    i intent to install vlc and opera

  12. nice, dude