Archives For wine 1.7

Wine 1.7.35

Wine 1.7.35, the latest development version of Wine for running Windows applications in Linux, was released a few hours ago.

The 1.7.35 release brings support for OpenGL core contexts, initial support for glyph placement in DirectWrite, and adds more WBEM objects. Also a total of 56 bugs has been fixed in this release. Source code and full list of changes are available at this page.

Wine running windows app in Linux

How to install / upgrade wine 1.7 in Ubuntu:

For Ubuntu users, besides building from the source you have to wait a few days for the official PPA updated for the latest binaries. Ubuntu 15.04, Ubuntu 14.10, and Ubuntu 14.04 are supported so far.

To add the PPA, open terminal from the Dash or by pressing Ctrl+Alt+T on keyboard. When it opens, run command:

sudo add-apt-repository -y ppa:ubuntu-wine/ppa

After that, upgrade Wine by installing available updates via “Software Updater” utility. Or install wine1.7 for the first time by running below two commands one by one:

sudo apt-get update

sudo apt-get install wine1.7

Since Wine PPA is not updating for Ubuntu 12.04, Precise users can use this unofficial PPA to get the latest wine release.

Before adding this PPA, you should remove the official PPA via command:

sudo add-apt-repository -r ppa:ubuntu-wine/ppa

Then add the new PPA for Ubuntu 12.04:

sudo add-apt-repository -r ppa:ricotz/unstable

Finally upgrade Wine1.7 through Update Manager, or install it via the previous two sudo apt-get command.

Wine

The official Wine PPA has stopped updating for Ubuntu 12.04 LTS. Since it still provides Wine 1.7.18, the latest development release has reached Wine 1.7.34.

Thanks to Rico Tzschichholz, a member from Gnome3 Team PPA has made the Wine 1.7.34 into PPA available for Ubuntu 12.04, Ubuntu 14.04, Ubuntu 14.10 and Ubuntu 15.04.

Wine 1.7.34

To add the PPA, open terminal from the Dash or by pressing Ctrl+Alt+T. When it opens, run command:

sudo add-apt-repository ppa:ricotz/unstable

Install Wine 1.7.34 in Ubuntu 12.04

After that, update system package cache and install/upgrade Wine1.7 via Software Updater or by running below commands one by one in terminal:

sudo apt-get update

sudo apt-get install wine1.7

That’s it.

Wine

The development version of Wine has reached the 1.7.34 release. Now it supports surround sound with DirectSound.

Besides that, Wine 1.7.34 brings:

  • Better text run support in DirectWrite.
  • Many HTML engine fixes.
  • More support for WBEM objects.
  • A few more C/C++ runtime functions.

And there are totally 63 bug fixes in this release:

  • avifil32 limits itself to max of 1024 frames when writing avis
  • Star Trek Klingon Academy 1.02: Ship textures are partly invisible
  • Adobe Photoshop CS2 tools stop working in maximised images
  • DPP (Digital Photo Professional): Instruments window returns to its starting position (in the center) automatically when the image windows is selected
  • X-Lite don`t work with ALSA driver correctly
  • .NET 2.0 SP2 installer fails (RegSvcs.exe bootstrapper expects updated assemblies while GAC update is deferred during install)
  • KP500-Utils-EN.exe fails silently to extract .kdz files
  • Warcraft 3: missing mouse cursor
  • ICQ 7 installer error message
  • Avant Browser needs HTMLElement_get_isTextEdit
  • Unhandled privileged instruction when starting Minitab 16 (Sentinel HASP hardlock.sys kernel driver tries to write to CR4/not handled in ntoskrnl emulate_instruction)
  • pyjamas desktop (python26 + python-comtypes MSHTML.DLL from IE8) fails due to unsupported ReadTypeLib header
  • Total Overdose: choppy audio playback with Diesel Power 3D sound system
  • Multiple 64-bit applications crash on startup (GetLocaleInfo() returns improper TCHAR count for LOCALE_IFIRSTDAYOFWEEK) (PowerGrep v4.x, RegexBuddy 4.x)
  • Compiling Ultracopier 0.4.0.3 inside Qt 5.0.1 results in errors from compiler
  • Trying to download flash from iexplore crashes in jscript
  • javascript basic DOM API functions fail
  • winmm/mci tests hang on PC-BSD
  • SWGEmu crashes everytime it tries to load
  • Artemis 2.0 crashes when loading the splash screen
  • Wine64 does not work on FreeBSD
  • Call of Duty: Ghosts needs psapi/kernel32 K32EnumProcessModulesEx
  • Multiple applications/installers fails due to SWbemLocator::ConnectServer being a stub (PSPad 4.5.7, Nitro PDF Professional 6.2.x, eTax 2008, GOG.com games)
  • Atom Zombie Smasher, Warhammer 40K: Dawn of War GOTY (Winter Assault) on Steam doesn’t start with Wine Mono 4.5.2
  • Loud audio distortion using wine 1.7.6 and up.
  • Macromedia Freehand 9 demo: invalid path for file association default icon causes stack overflow in winemenubuilder
  • BOINC 5.8.16: uninstall fails
  • Multiple applications/installers fail due to WinMGMTS_ParseDisplayName stub (PaintRibbon 1.x, MicroStation V8i)
  • dplayx interactive tests crash
  • Stronghold Kingdoms crashes due to ID3DXFont PreloadCharacters being a stub.
  • WHO Anthro software doesn’t work with Mono 4.5.2 (unimplemented System.Configuration.SettingValueElement.Unmerge)
  • dsound resampler causing clicks in StarCraft when resampling to 48000
  • Microsoft Office 2013 (15.0) and OneNote web installer crashes on unimplemented function IPHLPAPI.DLL.CreateSortedAddressPairs
  • PlayOn 3.9.13 settings tool fails to detect system memory size (needs ‘Win32_OperatingSystem’ WMI class ‘TotalVisibleMemorySize’ property)
  • vSphere 5.5 client ‘hcmon.sys’ driver crashes on unimplemented function ntoskrnl.exe.IoCsqInitialize
  • Hero Lab 5.x fails to retrieve updates
  • Multi Theft Auto: San Andreas 1.3.5 ‘FairplayKD.sys’ driver crashes on unimplemented function ntoskrnl.exe.KeSetSystemAffinityThread
  • Multiple games need X3DAudio1_7.dll (BeamNG v0.3 Tech Demo, Doom 3 BFG Edition)
  • WinHttpReceiveRequest goes into infinite blocking on 304 responses
  • WSAStringToAddress(“2001::1”, AF_INET, …) appears to succeed.
  • MaxQuant 1.4/1.5 (.NET 4.5 app) needs named entry point ‘Shell32.dll.SHILCreateFromPath’ in ‘Windows Vista’ mode
  • winefile command line does not support paths with spaces
  • YouTube Downloader crashes
  • Skype crashes trying to chat with anyone
  • Endless Space crashes on startup
  • Free YouTube to MP3 Converter 3.12 installer crashes on unimplemented function msvcr120.dll._wcsset_s
  • Propellerhead Reason 8 needs COMCTL32.dll.381 LoadIconWithScaleDown()
  • Propellerhead Reason 8 needs mfplat.dll.MFStartup
  • Personal Ancestral File 5 crashes when a new line is added in ‘Notes’ panel
  • Elevated demo silently exits
  • Saya no Uta: sound is all over the place after update
  • Propellerhead Reason 8 installer complains “interface not supported” during install
  • Airport Tycoon 2 demo fails to load with built-in msvcp70
  • Windows 8.1 Media Creation Tool: crashes due to unimplemented function VERSION.dll.GetFileVersionInfoSizeExW
  • N1MM PLUS Logger 1.0 (.NET 4.0 app) crashes on launch (failure to parse registration-free COM/ActiveX info from app manifest)
  • Cannot install Olympus Viewer 3
  • Bus Simulator 2012 crashes on startup
  • Autocad2006 crashes on unimplemented function [email protected][email protected]@[email protected]@@[email protected]@[email protected]@Z
  • SteuerSparErklärung 2015: crashes when starting a new tax case
  • Unable to license IAR Embedded Workbench Kickstart Edition 6.x/7.x (License Manager needs ‘Win32_ComputerSystemProduct’ WMI class)
  • PTC Mathcad Prime 3.0 Web installer crashes (‘Win32_LogicalDisk’ WMI class needs to provide ‘VolumeName’ property)
  • For loop %~$PATH:I feature works incorrect – PATH variable size limited by MAX_PATH

Install or Upgrade Wine 1.7 in Ubuntu:

The latest release will be made into the official PPA soon, available for Ubuntu 14.04, Ubuntu 14.10 and Ubuntu 15.04.

To add the PPA and install Wine 1.7, press Ctrl+Alt+T on keyboard to open terminal and run below commands one by one:

sudo add-apt-repository ppa:ubuntu-wine/ppa

sudo apt-get update

sudo apt-get install wine1.7

If you’ve already added the PPA repository and have an old 1.7 release installed, just run regular updates via Software Updater to keep it up-to-date.

Wine 1.7.20
 

The Wine development release 1.7.20 was released a few hours ago on June 13, 2014. Here’s how to install it in Ubuntu 14.04, Ubuntu 13.10 and Ubuntu 12.04.

Wine is a free and open source software that aims to allow applications designed for Microsoft Windows to run on Linux, Mac, FreeBSD, and Solaris.

The latest wine 1.7.20 brings below changes:

  • X11 drag & drop fixes.
  • A few more C/C++ runtime functions.
  • Fixes for various memory issues found by Valgrind.
  • Some OLE storage fixes.
  • 88 bug fixes.

Install Wine 1.7.20 via PPA:

Wine Team has created a PPA to make it easy to install Wine in Ubuntu and its derivatives. Check out the PPA page.

To add the PPA, press Ctrl+Alt+T on keyboard to open terminal, paste and run below command:

sudo add-apt-repository ppa:ubuntu-wine/ppa

Then update and install wine1.7:

sudo apt-get update; sudo apt-get install wine1.7

Install Wine 1.7.20 from source:

The PPA was usually updated a few days late than the release date. You can build it from source code if you don’t want to wait.

1. Install required packages:

For Ubuntu 14.04 and Ubuntu 13.10, run:

sudo apt-get install flex bison qt4-qmake

For Ubuntu 12.04, run:

sudo apt-get install flex bison qt3-dev-tools qt4-qmake

2. Download the source tarball:

wget http://prdownloads.sourceforge.net/wine/wine-1.7.20.tar.bz2

3. Unpack the source and navigate to the result folder:

tar -xjvf wine-1.7.20.tar.bz2 && cd wine-1.7.*

4. Compile and install wine 1.7.20. You may first check out 32-bit or 64-bit by going to System Settings -> Details.

For 32-bit, run below commands one by one:

./configure

cd tools && ./wineinstall

For 64-bit, run:

./configure --enable-win64

cd tools && ./wineinstall

Done!

Wine 1.7.12 Development

The Wine development release 1.7.12 is now available. According to the changelog, this release brings initial support for Window Media Player interfaces, some more Task Scheduler support, various C++ runtime fixes, and more dlls with ugly names for Windows 8 API set support.

As well as that, Wine 1.7.12 fixed totally 89 bugs. See the announcement for details.

Download:

The source is available from the link below:

wine-1.7.12.tar.bz2

The binary packages will be available soon in the Wine PPA. By then, you can run the commands below one by one in terminal (Ctrl+Alt+T) to install or upgrade to wine 1.7.12:

sudo add-apt-repository ppa:ubuntu-wine/ppa

sudo apt-get update

sudo apt-get install wine1.7

The PPA supports Ubuntu 14.04, Ubuntu 13.10, Ubuntu 12.10 and Ubuntu 12.04