Install Rigs of Rods on Ubuntu 13.04, Linux Mint via PPA

July 15, 2013 — 4 Comments

This brief tutorial will show you how to install the Rigs of Rods on Ubuntu 13.04 Raring and Linux Mint using the official repository.

Rigs of Rods (“RoR”) is an open source multi-simulation game which uses soft-body physics to simulate the motion and deformation of vehicles. The game was built using a specific soft-body physics engine called Beam, which simulates a network of interconnected nodes (forming the chassis and the wheels) and gives the ability to simulate deformable objects. With this engine, vehicles and their loads flex and deform as stresses are applied. Crashing into walls or terrain can permanently deform a vehicle.

The official ppa repository for Ubuntu 12.04 has been announced. So far it supports Ubuntu 13.04, 12.10, 12.04 and 11.10. Here’s how to install it:

Press Ctrl+Alt+T to open terminal, run command to add the ppa:

sudo add-apt-repository ppa:aapo-rantalainen/rigsofrods

rigs of rogs official repository

Then update package lists and install the package:

sudo apt-get update; sudo apt-get install rigsofrods

install rigs of rods ubuntu

Discuss: http://www.rigsofrods.com/threads/97932-Announcement-PPA-for-Ubuntu-12-04

I'm a freelance blogger who started using Ubuntu 5+ years ago and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me on Google Plus or email to ubuntuhandbook1@gmail.com

4 responses to Install Rigs of Rods on Ubuntu 13.04, Linux Mint via PPA

  1. I followed your instructions, and got error “E:Unable to locate package rigsofrogs”
    Then I tried running the install command again:

    sudo apt-get install rigsofrodsReading package lists… Done
    Building dependency tree
    Reading state information… Done
    E: Unable to locate package rigsofrods

    Here is the whole screen dump of what I did:
    user@user-Latitude-E6520 /tmp $ sudo add-apt-repository ppa:aapo-rantalainen/rigsofrods
    [sudo] password for user:
    You are about to add the following PPA to your system:
    Rigs of Rods
    Use:
    sudo add-apt-repository ppa:aapo-rantalainen/rigsofrods
    sudo apt-get update
    sudo apt-get install rigsofrods

    —–
    Discuss: ‘http://www.rigsofrods.com/threads/97932-Announcement-PPA-for-Ubuntu-12-04′
    —–
    Git repository for packaging: ‘https://gitorious.org/ror-ppa’

    libogre: ‘http://ogre3d.org/’
    angelscript: ‘http://www.angelcode.com/angelscript/’
    libmygui: ‘https://sourceforge.net/projects/my-gui/’
    ogre-paged: ‘https://code.google.com/p/ogre-paged/’
    caelum: ‘https://code.google.com/p/caelum/’
    socketw: ‘http://www.digitalfanatics.org/cal/socketw/’
    rigsofrods: ‘http://www.rigsofrods.com/’
    More info: ‘https://launchpad.net/~aapo-rantalainen/+archive/ubuntu/rigsofrods’
    Press [ENTER] to continue or ctrl-c to cancel adding it

    Executing: gpg –ignore-time-conflict –no-options –no-default-keyring –homedir /tmp/tmp.vYg9XKlsvX –no-auto-check-trustdb –trust-model always –keyring /etc/apt/trusted.gpg –primary-keyring /etc/apt/trusted.gpg –keyserver hkp://keyserver.ubuntu.com:80 –recv-keys 1462175F
    gpg: requesting key 1462175F from hkp server keyserver.ubuntu.com
    gpg: key 1462175F: public key “Launchpad aaporantalainen” imported
    gpg: Total number processed: 1
    gpg: imported: 1 (RSA: 1)
    user@user-Latitude-E6520 /tmp $ sudo apt-get update; sudo apt-get install rigsofrods



    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    E: Unable to locate package rigsofrods
    user@user-Latitude-E6520 /tmp $ sudo apt-get install rigsofrodsReading package lists… Done
    Building dependency tree
    Reading state information… Done
    E: Unable to locate package rigsofrods
    user@user-Latitude-E6520 /tmp $

    I’m running:
    Linux Mint 17.2 Cinnamon 64-bit 2.6.11

  2. Depois de atualizar instale usando
    $sudo apt-get install rigs of rods?

    deu essa mensagem
    E: Impossível encontrar o pacote rigsofrods.

  3. eu achei esta forma de instalar:
    sudo add-apt-repository ppa:aapo-rantalainen/rigsofrods
    sudo apt-get update
    sudo apt-get install rigsofrods

Leave a Reply

*

Text formatting is available via select HTML.

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>