GIMP 2.8.14 Fixed Broken Library Versioning in The Previous Release

August 28, 2014 — Leave a comment

install latest GIMP in Ubuntu

GIMP team just announced the release 2.8.14 the day after the previous release 2.8.12 with the broken library versioning fixed.

Yesterday’s 2.8.12 release had broken library versioning, so we had to roll out GIMP 2.8.14 today. The only change is the fixed libtool versioning. Please do not distribute any binaries of yesterday’s broken 2.8.12 release, and get GIMP 2.8.14 using the torrent:

GIMP image editor

Install / Upgrade to GIMP 2.8.14:

The GIMP PPA has been updated with the latest packages for Ubuntu 14.10, Ubuntu 14.04, and Ubuntu 12.04.

Press Ctrl+Alt+T on keyboard to open the terminal. When it opens, run the command below to add the PPA:

sudo add-apt-repository ppa:otto-kesselgulasch/gimp

After that, receive GIMP updates via Software Updater or run the commands below instead:

sudo apt-get update && sudo apt-get install gimp

I'm a freelance blogger who started using Ubuntu 5+ years ago and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me on Google Plus or email to

No Comments

Be the first to start the conversation.

Leave a Reply


Text formatting is available via select HTML.

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>