Linux Native Twitter Client ‘Corebird’ Sees a New Release

October 3, 2015

Corebird GTK+ 3 Twitter Client

Corebird discontinued! Try Cawbird as an alternative.

Corebird, Linux native GTK+3 twitter client, has reached the 1.1 release with lots of enhancments and bug fixes.

Changes in Corebird 1.1 according to the release note:

  • Tweets now get hidden/shown more correctly
  • Corebird now saves an application-wide list of snippets that you can use to insert common phrases or longer unicode emoticons. It can be found in the application settings in the “Snippets” tab.
  • Corebird now supports showing quote tweets in timelines as well as creating quote tweets. This replaces the old “Quote” item for tweets which would simply copy the original tweet’s text.
  • Media links and trailing hashtags can now be hidden via the “Tweets” tab in the application settings.
  • Profiles can now also show followers and followees
  • Twitter removed the 140 char limit on Direct Messages and so did we
  • Lots of other small enhancments and bug fixes
corebird-eos corebird-eos1

Corebird 1.1 now requires GTK >=3.16. Ubuntu 15.10 user can install the new release from PPA by running below commands one by one in terminal (Ctrl+Alt+T):

sudo add-apt-repository ppa:ubuntuhandbook1/corebird

sudo apt-get update

sudo apt-get install corebird

For those who don’t want to add PPA, grab the installer package from this page.

  • “corebird_1.1-1~15.10_amd64.deb” for 64-bit OS
  • “corebird_1.1-1~15.10_i386.deb” for 32-bit OS

I'm a freelance blogger who started using Ubuntu 5+ years ago and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me on Google Plus or email to

4 responses to Linux Native Twitter Client ‘Corebird’ Sees a New Release

  1. I get

    corebird : Depends: libgtk-3-0 (>= 3.11.2) but 3.10.8-0ubuntu1.6 is to be installed

    and the installation fails.

  2. 15.10 is now supported?

    • Yes, the new release now depends on GTK >=3.16. You need 15.10 (or 15.04 with Gnome 3 PPA) to get it from PPA.