Native GTK+3 Twitter App Corebird 1.3 Released

July 31, 2016 — 2 Comments

Corebird Twitter Client

Corebird, an open-source GTK+3 twitter app, has reached the 1.3 release with some new features and build system improvements.

Corebird 1.3 changelog:

  • The build system will now check for gtksink
  • Remove libgee dependency
  • The compose tweet window will now save the current text on cancel
  • Allow self-retweeting
  • Fade loaded inline media in
  • Twitter wont send mp4 urls for their videos anymore starting August 1st, so support HLS videos
  • Query full-length DMs
  • Support muting in profiles

Corebird Twitter Client 1.3

How to install Corebird 1.3 in Ubuntu 16.04:

Besides building the software from source, you can install the latest release from third-party PPA, Ubuntu 16.04 and its derivatives are supported.

1. Add PPA

Open terminal (Ctrl+Alt+T) and run the command below to add the PPA:

sudo add-apt-repository ppa:ubuntuhandbook1/corebird 

Type in your password when it prompted and hit Enter.


2. If you have a previous release installed, just launch Software Updater and upgrade it after checking for updates.

upgrade corebird 1.3

Or run the commands below one by one in terminal to update and install Corebird Twitter client:

sudo apt update

sudo apt install corebird

3. (Optional) For those who want to revert to Corebird 1.1, the stock version in Ubuntu 16.04, purge the PPA via ppa-purge:

sudo apt install ppa-purge && sudo ppa-purge ppa:ubuntuhandbook1/corebird

That’s it. Enjoy!

I'm a freelance blogger who started using Ubuntu 5+ years ago and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me on Google Plus or email to

2 responses to Native GTK+3 Twitter App Corebird 1.3 Released

  1. problem here
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    corebird : Depends: libgtk-3-0 (>= 3.11.2) but 3.10.8-0ubuntu1.6 is to be installed
    E: Unable to correct problems, you have held broken packages.

    • Seems that you’ve Ubuntu 14.04 or Linux Mint 17.x, sorry to say the 1.3 release requires GTK+ >=3.16, and Ubuntu 16.04 or Linux Mint 18 is required.

      Run sudo apt-get -f install command to fix broken packages issue, and remove the PPA via Software & Updater under Other Software tab.

Leave a Reply


Text formatting is available via select HTML.

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>