How to Install Sigil Epub Editor For Ubuntu via PPA

August 2, 2013

This simple tutorial shows you how to install Sigil WYSIWYG epub editor on Ubuntu 13.04 Raring, 12.04 Precise via Sigil PPA repository.

sigil epub editor for ubuntu

Sigil is a free and open-source EPUB ebook editor. It runs on Linux, Windows and Mac with full EPUB 2 spec and UTF-16 support.

  • Multiple Views: Book View, Code View and Preview View
  • WYSIWYG editing in Book View
  • Complete control over directly editing EPUB syntax in Code View
  • Table of Contents generator with multi-level heading support
  • Metadata editor with full support for all possible metadata entries (more than 200) with full descriptions for each
  • User interface translated into many languages
  • Spell checking with default and user configurable dictionaries
  • Full Regular Expression (PCRE) support for Find & Replace
  • Supports import of EPUB and HTML files, images, and style sheets,
  • Documents can be validated for EPUB compliance with the integrated FlightCrew EPUB validator
  • Embedded HTML Tidy: all imported files have their formatting corrected, and your editing can be optionally cleaned

Install Sigil Epub Editor:

There is only a personal Sigil PPA for Ubuntu users. Now supports Ubuntu 14.10 and Ubuntu 14.04. Supports Ubuntu 13.10, Ubuntu 13.04, Ubuntu 12.04, Ubuntu 12.10. Use it at your own risk!

Press Ctrl+Alt+T on your keyboard to open terminal. When it opens, run below commands to add the ppa:

sudo add-apt-repository ppa:sunab/sigil-release

For Ubuntu 12.10, Ubuntu 12.04, you’ll need the Ubuntu SDK PPA:

sudo add-apt-repository ppa:ubuntu-sdk-team/ppa

After adding the ppa repository, you’re able to install the editor via below commands:

sudo apt-get update; sudo apt-get install sigil

sigil epub editor for ubunt unity

I'm a freelance blogger who started using Ubuntu 5+ years ago and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me on Google Plus or email to ubuntuhandbook1@gmail.com

7 responses to How to Install Sigil Epub Editor For Ubuntu via PPA

  1. Failed on Xubuntu 12.04 ,
    novice user fault?

    The following packages have unmet dependencies:
    sigil : Depends: libqt5concurrent5 (>= 5.0.2) but it is not installable
    Depends: libqt5core5 (>= 5.0.2) but it is not installable
    Depends: libqt5gui5 (>= 5.0.2) but it is not installable
    Depends: libqt5network5 (>= 5.0.2) but it is not installable
    Depends: libqt5printsupport5 (>= 5.0.2) but it is not installable
    Depends: libqt5webkit5 but it is not installable
    Depends: libqt5widgets5 (>= 5.0.2) but it is not installable

  2. Great working 100% on Xubuntu 12.04,after install SDK PPA!
    Thanks!

  3. great working on Linuxmint 16

  4. Works fine in Ubuntu 14.04. Without instaling the SDK. Thanks!

  5. Kevin Krumwiede April 23, 2015 at 3:16 am

    Sigil is supposed to have a menu bar, which is the only place to change the font. The menu bar is missing from all the PPAs I’ve found, including this one.