How to Upgrade to Ubuntu 17.04 from Ubuntu 16.10

April 12, 2017 — 6 Comments

upgrade Ubuntu 17.04

This is a quick tip for Ubuntu 16.10 desktop users how to upgrade to Ubuntu 17.04 Zesty Zapus.

Before getting started, you need to do some preparations:

1. Always make a backup of important data, bookmarks, and other user documents.

2. Remove or disable third-party repositories.

Launch Software & Updates utility, navigate to Other Software tab, and remove /disable all third-party repositories.

3. Restore to open-source drivers.

Also in Software & Updates utility, Additional Drivers tab, switch to the open-source drivers if proprietary drivers are in use. (Need restore after applied changes)

4. And it’s better to choose download from ‘Main Server’ in Software & Updates utility.

5. Make your system up-to-date by running command in terminal:

May need to restart if you have not update your system for a long time.

6. (Optional) Useless packages and software libraries may take a few more minutes upgrading your system. For me, Ubuntu Kylin and Plasma Desktop libraries take quite a few minutes in the upgrading process.

After all, launch Update Manager via the command below and it will prompt that Ubuntu 17.04 is available after checking for updates:

sudo update-manager -d

Click the Upgrade and confirm in the next dialog, follow the wizard util done.

I'm a freelance blogger who started using Ubuntu 5+ years ago and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me on Google Plus or email to ubuntuhandbook1@gmail.com

6 responses to How to Upgrade to Ubuntu 17.04 from Ubuntu 16.10

  1. Hi, I have troubles (ubuntu 17.04) connecting to the wifi, It requires the password but nothing happened. I read it is an issue with the kernel, Anybody knows if the issue has been solved?

  2. The following packages have unmet dependencies:
    libubuntu-app-launch4 : Depends: ubuntu-app-launch (= 0.12+17.04.20170404.2-0ubuntu2) but 0.9+16.10.20160928-0ubuntu1 is to be installed
    ubuntu-app-launch-tools : Depends: ubuntu-app-launch (= 0.12+17.04.20170404.2-0ubuntu2) but 0.9+16.10.20160928-0ubuntu1 is to be installed
    url-dispatcher-tools : Depends: url-dispatcher (= 0.1+17.04.20170328-0ubuntu2) but 0.1+16.10.20160816.1-0ubuntu1 is to be installed
    E: Unmet dependencies. Try ‘apt –fix-broken install’ with no packages (or specify a solution).

  3. Hello I tried to upgrade from 16.10 to 17.04. It return me the error
    ” E:Method mirror has died unexpectedly!, E:Sub-process mirror received a segmentation fault. ” telling me that is an connection issue. May I have any help ?

Leave a Reply

Text formatting is available via select HTML.

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> 

*