WireShark 1.10.2 Released, Install it in Ubuntu and Linux Mint

September 11, 2013 — 1 Comment

WireShark logoAs you may know, WireShark is a network ‘sniffer’ that captures and analyzes packages off the wire. It’s available in Ubuntu Software Center, but it’s a little old. The latest version has reached 1.10.2 and this tutorial will show you how to install it in Ubuntu 13.04, Ubuntu 12.10, Ubuntu 12.04 and Linux Mint.

WireShark 1.10.2 updated the following protocols: ASSA R3, ASN.1 PER, Bluetooth HCI ACL, GTPv2, EtherCAT AMS, HTTP, IEEE 802.11, ISDN SUP, IPFIX, LDAP, NBAP, MQ, Novell SSS, Radiotap, PROFINET MRP, ROHC, SCSI, SIP, STP, and RTPS. Support for pcap-ng and Microsoft Network Monitor was also updated. Moreover, lots of vulnerabilities have been fixed and numerous bugs have been squashed. See the announcement

Install WireShark 1.10.2:

For Ubuntu 12.04 Precise:

Press Ctrl+Alt+T on your keyboard to open terminal. When it opens, run below command to add the PPA:

sudo add-apt-repository ppa:whoopie79/ppa

Update and install wireshark:

sudo apt-get update; sudo apt-get install wireshark

For Ubuntu 13.04 Raring:

Run commands below one by one:

sudo add-apt-repository ppa:n-muench/programs-ppa

sudo apt-get update

sudo apt-get install wireshark

For Ubuntu 13.10 and higher, install it from Ubuntu Software Center after checking for updates.

I'm a freelance blogger who started using Ubuntu 5+ years ago and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me on Google Plus or email to ubuntuhandbook1@gmail.com

One response to WireShark 1.10.2 Released, Install it in Ubuntu and Linux Mint

  1. I am gettting the following error

    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    You might want to run ‘apt-get -f install’ to correct these:
    The following packages have unmet dependencies:
    wireshark : Depends: libwireshark3 but it is not going to be installed
    Depends: libwiretap3 but it is not going to be installed
    Depends: libwsutil3 but it is not going to be installed
    Depends: wireshark-common (= 1.10.3-1~precise1) but 1.6.7-1 is to be installed
    wireshark-common : Depends: libwireshark1 (>= 1.6.7-1) but it is not going to be installed
    Depends: libwiretap1 (>= 1.6.7-1) but it is not going to be installed
    Depends: libwsutil1 (>= 1.6.0-1) but it is not going to be installed
    E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).

Leave a Reply

*

Text formatting is available via select HTML.

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>