Install Corebird GTK+ Twitter Client in Ubuntu 14.10/14.04 via PPA

July 15, 2014 — 11 Comments

Corebird Native Gtk twitter client

Never heard of Corebird? It’s a native GTK+ Twitter client for Linux which has a modern and responsive design that looks kinda similar to the official Twitter app for Mac.

Corebird is a free and open source project created by Timm Bäder, AKA “baedert”. It carries the whole essential twitter features, such as Streaming of Tweets, Mentions/Notifications, Favorites, Direct Messaging, Lists, Filters and an integrated search.

With the advantage of the latest GTK+3 features, the application makes use of the new Header Bars. With the gstreamer and gstreamer plugins, corebird allows to view any videos (i.e. no vines and no twitter gifs).

The application is well intergrated with with GNOME Desktop. It supports GNOME Shell Application Menu and displays the number of Twitter notifications on the lockscreen.

Screenshots (ubuntu 14.04 64-bit):

corebird-ubuntu Corebird Twitter Client in Ubuntu
corebird twitter client in Ubuntu 14.04 Corebird Twitter Client in Ubuntu 14.04

Install Corebird in Ubuntu via PPA:

I’ve successfully built this twitter client into my PPA, available for Ubuntu 14.10 and Ubuntu 14.04.

Corebird depends on gtk+3 (>= 3.12), so Ubuntu 14.04 user need to add GNOME3 and GNOME3 Staging PPA. As the Staging PPA is for test use, it might break your system, use it at your own risk!!

1. (For Ubuntu 14.04 only) Press Ctrl+Alt+T on keyboard to open the terminal. When it opens, run the commands below one by one to add the required PPAs:

sudo add-apt-repository ppa:gnome3-team/gnome3

sudo add-apt-repository ppa:gnome3-team/gnome3-staging

2. (For both Ubuntu 14.10 & 14.04) Add my PPA and install corebird:

sudo add-apt-repository ppa:ubuntuhandbook1/corebird

sudo apt-get update

sudo apt-get install corebird

Or grab the .deb package directly from HERE.

Once installed, remove Gnome 3 Staging PPA via:

sudo add-apt-repository -r ppa:gnome3-team/gnome3-staging

Project page

I'm a freelance blogger who started using Ubuntu 5+ years ago and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me on Google Plus or email to ubuntuhandbook1@gmail.com

11 responses to Install Corebird GTK+ Twitter Client in Ubuntu 14.10/14.04 via PPA

  1. Thanks.

  2. Parker (@pgrytdal) July 19, 2014 at 2:45 am

    Even though I added the Gnome packages, I get this error:

    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    corebird : Depends: libgtk-3-0 (>= 3.11.2) but 3.10.8~3+qiana is to be installed
    E: Unable to correct problems, you have held broken packages.

  3. Jesús Abelardo Saldívar November 11, 2014 at 9:44 pm

    I installed Corebird on Ubuntu 14.10 via this PPA, but it doesn’t work well: Timeline windows have transparent background, so I can’t read.

    screenshot: http://i.imgur.com/UgOXTdu.png

    • This is a bug due to the Unity overlay scroll bars. A workaround is to use the old fat scroll bars by launching the twitter client via below command:

      LIBOVERLAY_SCROLLBAR=0 corebird
  4. hello Ji m first thank u for all ur info but i want ask u i have ubuntu 14.04 64bit using unity desktop so how can install corebird and corebird need gnome 3 ? should be change desktop from unity to gnome or no ?

    thank u

    • Corebird depends on some gnome 3 libraries, but you don’t need to install the Gnome3 Desktop, though it looks better in gnome-shell.

      Again corebird needs the Gnome3 Staging PPA for the higher GTK version for Ubuntu 14.04. But the PPA is not stable for use, use it at your own risk!

  5. Aitor Cereceto Benavente October 28, 2015 at 7:46 pm

    Hello Ji! Any possibility to have 1.1 in 14.04? I tried to install every dependency and every third partner program and I can’t get in

    • Ubuntu 15.10 (or Ubuntu 15.04 with gnome PPA) is required. Please remove those dependency PPAs after because they contain unstable packages that may break you system.

Leave a Reply

*

Text formatting is available via select HTML.

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>