Fix Slow Shutdown ‘systemd-shutdown[1]: waiting for process: crond’ Issue

Last updated: December 3, 2021 — 1 Comment

My Ubuntu laptop recently runs into a power-off issue. Every time when I shutdown or reboot the machine, it stuck at blank screen with text message “systemd-shutdown[1]: waiting for process: crond” for more than a minute.

According to the keyword ‘crond‘, it has something to do with the cron schedule job. And, thanks to this thread, user may run the command below to list all current schedule cron jobs:

find /etc/cron* -type f | xargs  ls -ltr

And there you’ll find that the schedule job ‘/etc/cron.d/collect‘ tries to run an unknown crond binary under ‘/var/tmp’ every 10th minute (e.g., 5:10, 5:20, 5:30 …). So the problem may not occur when shutdown/reboot within a few minutes after login.

The /var/tmp directory stores temporary files or folders that are preserved between system reboots. According to @bird7676 in that thread, the files were probably created by Free Download Manager.

Solution:

If you don’t use and have removed the Free Download Manager, simply remove these temporary files as well as the schedule job.

To do so, either use a system cleaner (e.g., BleachBit), or press Ctrl+Alt+T on keyboard to open terminal and run command below to remove the files:

sudo rm /etc/cron.d/collect /var/tmp/crond /var/tmp/bs

If the app is important for you, you may run ‘mv‘ command to move the files to another location or backup unfinished downloads before deleting them.

NOTE: while the binary may be still running though you have removed the file, you may need to shutdown/reboot twice to check if the problem is fixed.

Twitter

I'm a freelance blogger who started using Ubuntu in 2007 and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me via [email protected]

One response to Fix Slow Shutdown ‘systemd-shutdown[1]: waiting for process: crond’ Issue

  1. I’ve run into this problem a few times with mysql. However, it seems to be fixed now. I assume it was fixed in an update.

Leave a Reply

Text formatting is available via select HTML.

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> 

*

This site uses Akismet to reduce spam. Learn how your comment data is processed.