Youtubedl-gui: New Graphical YouTube Downloader based on Youtube-DL

January 17, 2021 — 3 Comments

Youtubedl-gui is a simple new graphical interface for the popular command-line YouTube downloader youtube-dl.

The tool is quite simple to use, just paste the video URL, select audio quality and format, video resolution and format, and click download! And of course, there’s an option to change the destination folder of your downloads.

Once you click download, a small dialog will pop up with the process bar.

How to Install Youtubedl-gui in Ubuntu:

Just note for legal reasons you need permission to download videos from youtube.

The software developer maintains an Ubuntu PPA contains the packages for Ubuntu 20.04, Ubuntu 20.10, and Linux Mint 20.

Open terminal from system application launcher and do following steps one by one:

1.) Run commands one by one to install the latest youtube-dl if you don’t have it:

sudo wget https://yt-dl.org/downloads/latest/youtube-dl -O /usr/local/bin/youtube-dl

sudo chmod a+rx /usr/local/bin/youtube-dl

2.) Add the developer’s PPA by running command:

sudo add-apt-repository ppa:mordec13/youtubedl-gui

3.) Finally install the tool:

sudo apt install youtubedl-gui

Uninstall Youtubedl-gui:

For any reason, you can remove the software easily via command:

sudo apt remove youtubedl-gui

And remove the Ubuntu PPA either via Software & Updates -> Other Software or by running command:

sudo add-apt-repository --remove ppa:mordec13/youtubedl-gui

Twitter

I'm a freelance blogger who started using Ubuntu in 2007 and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me via [email protected]

3 responses to Youtubedl-gui: New Graphical YouTube Downloader based on Youtube-DL

  1. Waited awhile for the gui version to back after 18.04+ nuked dependencies. I’ve been using TarTube in the interim buts is way overboard than just what gui used to be.

    I’m getting errors when installing from PPA:

    dpkg: error processing package youtubedl-gui (–configure):
    installed youtubedl-gui package post-installation script subprocess returned error exit status 1
    Errors were encountered while processing:
    youtubedl-gui

    I do have pip3 version of youtube-dl installed, not the standard one. And install says: Requirement already satisfied: youtube-dl in /usr/local/lib/python3.8/dist-packages (2021.1.16)
    gtk-update-icon-cache: The generated cache was invalid.

    Any thoughts?

  2. Looks like this is important for Ubuntu install 20.04+:

    sudo apt install build-essential qt5-default qtdeclarative5-dev ffmpeg

    and I was able to do:

    git clone https://github.com/JaGoLi/ytdl-gui.git
    cd ytdl-gui
    make
    sudo make install

    but audio and video still don’t download; get errors

  3. Did not install for me after installing the developer’s PPA. I am using Linus Mint 19.3 Tricia.
    [email protected]:~$ sudo apt install youtubedl-gui
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    E: Unable to locate package youtubedl-gui

Leave a Reply

Text formatting is available via select HTML.

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> 

*

This site uses Akismet to reduce spam. Learn how your comment data is processed.