VLC 3.0.21 Released with AMD Super Resolution Support

Last updated: June 7, 2024 — 3 Comments

VLC, the popular free open-source media player, released version 3.0.21 after more than half a year of development.

The release introduced AMD HQ Scaler support for Super Resolution scaling with AMD GPUs. Meaning, user can now use this AI-assisted feature to improve the quality and sharpness of playback with NVIDIA RTX series (and more listed in this page), AMD Radeon™ RX 5000 Series Graphics and newer, and Intel Arc, Xe-LP GPUs.

If you have a compatible GPU, then you can enable this feature in Preferences dialog, under Video -> Output modules section.

The release also added D3D11 option to use NVIDIA TrueHDR to generate HDR from SDR sources, as well as D3D11 option allows to disable/enable HDR on SDR and HDR screens on demand, on any GPU.

Other changes in VLC 3.0.21 include:

  • AMF VQ Enhancer video filter.
  • Fix VAAPI hardware decoding and filters with r600 Mesa driver.
  • Improve Opus ambisonic support.
  • Fix some ASS subtitle rendering issues.
  • Fix Opus in MP4 behavior.
  • Add support for HTTP content range handling according to RFC 9110.
  • Fix some HLS Adaptive Streaming not working in audio-only mode.
  • Improve subtitles rendering on Apple platforms of notably Asian languages by correcting font fallback lookups.
  • Fix regression on macOS causing crashes when using audio devices with more than 9 channels.
  • Fix exposed UPnP directory URL schemes to be compliant with RFC 398.
  • Fix crashes when using caopengllayer.

How to Install VLC 3.0.21

VLC website provides the binary package for all supported platforms:

At the moment of writing, the download page is however not updated for the new 3.0.21 release. Though, the source code is available HERE.

For Ubuntu, user can search and install the Snap package from Ubuntu Software (or App Center), which runs in sandbox environment.

Or, install the native .deb package from this unofficial PPA, by running the commands below one by one in terminal (Ctrl+Alt+T).

sudo add-apt-repository ppa:ubuntuhandbook1/vlc
sudo apt update
sudo apt install vlc

For choice, VLC is also available to install as Flatpak package, though also runs in sandbox environment and unofficial (not verified by VideoLAN).

Twitter

I'm a freelance blogger who started using Ubuntu in 2007 and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please comment to let me know if the tutorial is outdated! And, notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me via [email protected] Buy me a coffee: https://ko-fi.com/ubuntuhandbook1

3 responses to VLC 3.0.21 Released with AMD Super Resolution Support

  1. The following packages have unmet dependencies:
    vlc-plugin-base : Depends: liblivemedia112 (>= 2024.05.30) but it is not installable
    E: Unable to correct problems, you have held broken packages.

    • As far as I know, only VLC in Rob Savoury’s PPA has package depends on liblivemedia112 (>= 2024.05.30). The PPA includes too much dependency libraries for most features, but easy for beginners to run into dependency hell!

      Launch “Software & Updates”, then navigate to “Other Software” tab. You’ll see the similar line below if you have that PPA added into your system.

      https://ppa.launchpadcontent.net/savoury1/vlc3/ubuntu CODENAME main

      To fix the issue, either follow the description (see the PPA link) to add the all the dependency PPAs, then try installing VLC from that PPA. Or, purge that PPA to get rid of all the packages from it.

      sudo apt install ppa-purge && sudo ppa-purge ppa:savoury1/vlc3

      If you don’t have that PPA, then it could be a legacy package that caused the issue. Try running command to uninstall it as well as all dependencies:

      sudo apt remove --autoremove vlc-plugin-base

      NOTE that other software packages may be also installed with Rob Savoury’s PPA packages as dependency. These software packages in the case will be also removed.

Leave a Reply

Text formatting is available via select HTML.

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> 

*