Voice Chat App Mumble 1.3.4 Released with Important Bug-fixes

Last updated: February 11, 2021 — Leave a comment

Mumble, voice chat app for gamer, released version 1.3.4 with important bug-fixes.

Mumble is a free and open-source VoIP application designed for use by gamer and is similar to programs such as TeamSpeak.

Before, the public server list registration script doesn’t have an URL scheme whitelist for the website field. So a malicious server can register itself with a dangerous URL in an attempt to attack a user’s machine. In Mumble 1.3.4, now it only allows http and https schemes in both client-side and public server lists.

The new release also fixed an issue that applying a noise gate generates significant packet loss. Due to the mitigation for vulnerabilities discovered in OCB2, it allows some packets with specific characteristics to be dropped during encryption. It however causes packet loss issue. Now it is fixed by a workaround from contributor.

Other changes in Mumble 1.3.4 include:

  • Don’t use outdated (non-existent) notification icon names on Linux.
  • Use qInfo instead of qFatal for logging, which fixes a crash issues.

Unfortunately, there are still known issues in Mumble that overlay blocked by CS:GO Trusted Mode and BattleEye.

How to install Mumble 1.3.4 in Ubuntu:

The official release PPA has made the packages for Ubuntu 16.04, Ubuntu 18.04, and Ubuntu 20.04.

1. Open terminal either from system application launcher or by pressing Ctrl+Alt+T on keyboard. When it opens, paste the command below and hit run:

sudo add-apt-repository ppa:mumble/release

Type user password (no asterisk feedback) when it prompts and hit Enter to continue adding the PPA.

2. If an old release was installed, simply upgrade it via Software Updater:

Or run commands one by one in terminal to check updates and install the chat app for gamer:

sudo apt-get update

sudo apt-get install mumble mumble-server

Uninstall Mumble:

You can purge the PPA which also downgrade the VoIP app to the stock version via command:

sudo apt-get install ppa-purge && sudo ppa-purge ppa:mumble/release

To simply remove mumble, either use system package manager or run command in terminal:

sudo apt-get remove mumble mumble-server

Twitter

I'm a freelance blogger who started using Ubuntu in 2007 and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me via [email protected]

No Comments

Be the first to start the conversation.

Leave a Reply

Text formatting is available via select HTML.

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> 

*

This site uses Akismet to reduce spam. Learn how your comment data is processed.