digiKam 4.14.0 Released, PPA for Ubuntu 14.04, 15.04

October 18, 2015 — 2 Comments


digiKam 4.14.0, the last stable release of the 4.x series, has been released. The next 5.0.0 release with Qt5 and KF5 support is on the way.

In this release, OpenCV 3.x is now supported for face management and others tools based on OpenCV algorithm. Some work have been done about overlay icon to improve usability. Icons are now re-sized accordingly with thumbnail sizes, and a new icon have been add to quickly run slideshow in full-screen mode.

digiKam 5.0 beta splash screen

digiKam 5.0 beta splash screen

How to install / upgrade digikam in Ubuntu:

Open terminal from the Application Launcher or via Ctrl+Alt+T shortcut key. When it opens, run below commands one by one to get the latest digiKam from Philip Johnsson’s PPA.

1. Choose a PPA to add to your system.

For Ubuntu 14.04 with Kubuntu Backports PPA added, run command to add PPA:

sudo add-apt-repository ppa:philip5/kubuntu-backports

For Ubuntu 14.04 and Ubuntu 15.04 with default KDE libraries, use below command instead:

sudo add-apt-repository ppa:philip5/extra 


2. Update system repository cache and install/upgrade digiKam:

sudo apt-get update

sudo apt-get install digikam

I'm a freelance blogger who started using Ubuntu 5+ years ago and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me on Google Plus or email to ubuntuhandbook1@gmail.com

2 responses to digiKam 4.14.0 Released, PPA for Ubuntu 14.04, 15.04

  1. Don’t work on Ubuntu 14.04, got that error on two different computers:

    root@Fixe:~# apt-get install digikam
    Lecture des listes de paquets… Fait
    Construction de l’arbre des dépendances
    Lecture des informations d’état… Fait
    Certains paquets ne peuvent être installés. Ceci peut signifier
    que vous avez demandé l’impossible, ou bien, si vous utilisez
    la distribution unstable, que certains paquets n’ont pas encore
    été créés ou ne sont pas sortis d’Incoming.
    L’information suivante devrait vous aider à résoudre la situation :

    Les paquets suivants contiennent des dépendances non satisfaites :
    digikam : Dépend: libkgeomap2 (>= 1.0~digikam4.14.0) mais ne sera pas installé
    E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l’état ».

  2. @Vincen: I have add both PPAs
    sudo add-apt-repository ppa:philip5/kubuntu-backports
    sudo add-apt-repository ppa:philip5/extra
    in my Linux Mint 17.3 mate and I am able to install Digikam.
    And, it is working perfectly fine for me.

Leave a Reply


Text formatting is available via select HTML.

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>