How to Install Komodo Edit on Ubuntu 13.04, 12.04, 12.10

Last updated: July 25, 2013

This simple tutorial shows how to install latest Komodo edit on Ubuntu 13.04 Raring, 12.10 Quantal, 12.04 Precise via ppa repository.

komodo ubuntu

Komodo Edit, based on the award-winning Komodo IDE, offers sophisticated support for all major scripting languages, including in-depth autocomplete and calltips, multi-language file support, syntax coloring and syntax checking, Vi emulation, Emacs key bindings. It provides dynamic language expertise for Perl, PHP, Python, Ruby, and Tcl, plus JavaScript, CSS, HTML, and XML, and template languages like RHTML, Template-Toolkit, HTML-Smarty and Django.

Install Komodo Edit

A PPA repository has been created for Ubuntu users. So far it supports Ubuntu 13.04, 12.04 and 12.10.

To add the repository, press Ctrl+Alt+T on your keyboard to open terminal. When it opens, run below commands:

sudo add-apt-repository ppa:mystic-mirage/komodo-edit

After that, update your package lists and install this tool via command below:

sudo apt-get update; sudo apt-get install komodo-edit

Once installed, open it by running komodo command. You may need to manually create launcher shortcut


I'm a freelance blogger who started using Ubuntu in 2007 and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please comment to let me know if the tutorial is outdated! And, notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me via [email protected] Buy me a coffee:

8 responses to How to Install Komodo Edit on Ubuntu 13.04, 12.04, 12.10

  1. thank’s it’s helpful

  2. thanks for your useful information, you save my time :)

  3. realy very simple way its working thank you]

  4. I got this error when installing komodo

    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    komodo-edit : Depends: libc6 (>= 2.17) but 2.15-0ubuntu10.7 is to be installed
    Depends: libfontconfig1 (>= 2.9.0) but 2.8.0-3ubuntu9.1 is to be installed
    Depends: libglib2.0-0 (>= 2.37.3) but 2.32.4-0ubuntu1 is to be installed
    Depends: libpango-1.0-0 (>= 1.22.0) but it is not installable
    Depends: libpangocairo-1.0-0 (>= 1.14.0) but it is not installable
    E: Unable to correct problems, you have held broken packages.

  5. Thank you :)