Pandora Client Pithos 1.5.1 Released [Ubuntu PPA]

Last updated: September 13, 2022 — 3 Comments

Pithos, native Pandora Radio client for Linux, released version 1.5.1 a day ago with minor bug-fixes and improvements.

Pithos is much more lightweight than the Pandora.com web client, and integrates with desktop features such as media keys, notifications, and the sound menu. The latest v1.5.1 release highlights include:

  • Add Quit to the app menu
  • Remove the limit of 95 stations
  • Handle Enter keypress in stations search
  • Fix app menu keybindings failing to work
  • Fix syntax error on Python 3.8
  • Fix an exception on newer versions of pygobject
  • Fix album art downloads in Flatpak
  • MPRIS: Fix media keys failing to bind on KDE

How to Install Pithos 1.5.1 in Ubuntu / Linux Mint:

If you’re OK with the containerized flatpak package. Pithos 1.5.1 has been made into flathub.org for most Linux systems.

For those prefer .deb package, the unofficial PPA is available for Ubuntu 18.04, Ubuntu 20.04, Linux Mint 20, Ubuntu 22.04.

1. Open terminal and run command to add the PPA:

sudo add-apt-repository ppa:ubuntuhandbook1/apps

2. Then check updates and install the client:

sudo apt update

sudo apt install pithos

How to Remove Pithos:

To remove the PPA, either go to Software & Updates -> Other Software or run command in terminal:

sudo add-apt-repository ppa:ubuntuhandbook1/apps

And to remove the Pandora client, run command:

sudo apt remove --autoremove pithos

Twitter

I'm a freelance blogger who started using Ubuntu in 2007 and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please comment to remind me outdated tutorial! And, notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me via [email protected] Buy me a coffee: https://ko-fi.com/ubuntuhandbook1

3 responses to Pandora Client Pithos 1.5.1 Released [Ubuntu PPA]

  1. Could you teach us a simpler way to install this:

    https://github.com/lucianodato/speech-denoiser

    I for one would really appreciate this. TIA!

  2. Not working on 20.xx Linux Mint
    Error seen:
    The following packages have unmet dependencies:
    pithos : Depends: gstreamer1.0-plugins-bad but it is not going to be installed

  3. I installed this under Linux Mint 21 using the instructions provided here and instead of Pithos 1.5.1 version 1.1.2 was installed.

Leave a Reply

Text formatting is available via select HTML.

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> 

*

This site uses Akismet to reduce spam. Learn how your comment data is processed.