How to Install Remmina RDC 1.4.7 via PPA in Ubuntu 20.04

July 19, 2020

Prefer installing app via apt rather than the containerized Snap or Flatpak package? Here’s how to install the latest Remmina Remote Desktop Client 1.4.7 via PPA in Ubuntu 20.04.

Remmina is a GTK+ remote desktop client that supports RDP, VNC, SPICE, NX, XDMCP, SSH and WWW. It’s pre-installed in Ubuntu 20.04 but old.

Besides installing the Snap (or Flatpak) package from Ubuntu Software. You can get the latest .deb packages from the “Remmina PPA Team” PPA. So far Ubuntu 16.04, Ubuntu 18.04, Ubuntu 19.10, Ubuntu 20.04 are supported.

1.) Open terminal from your system application launcher. When it opens, run command to add the PPA:

sudo add-apt-repository ppa:remmina-ppa-team/remmina-next

Type user password (no asterisk feedback) for sudo prompts and hit Enter to continue.

NOTE the official website refers to the PPA though it’s marked for next branch.

2.) Then upgrade Remmina package via Software Updater (Update Manager):

You may also run command to install EXEC, KWallet, NX, WWW plugins:

sudo apt install remmina-plugin-exec remmina-plugin-www remmina-plugin-nx remmina-plugin-kwallet

How to Restore:

To remove the PPA as well as downgrade Remmina to the stock version, run command in terminal:

sudo apt install ppa-purge && sudo ppa-purge ppa:remmina-ppa-team/remmina-next

Twitter

I'm a freelance blogger who started using Ubuntu in 2007 and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me via [email protected]

3 responses to How to Install Remmina RDC 1.4.7 via PPA in Ubuntu 20.04

  1. Jonathan Neufeld January 20, 2021 at 5:01 pm

    Please don’t baby me, I am a senior dev and I am more interested in EFFICIENCY than CONVENIENCE. Give me *.{deb,tar.gz} or give me death!

  2. Hello there,
    I upgraded Remmina via apt-get, but I ended up having two versions of the software on my pc: 1.4.2 and 1.4.10.
    It gets often confusing.
    Do you have any idea about how I can get rid of the base version?

    Thank you very much!
    BG