How to Install KDE Plasma 5.4 in (K)Ubuntu 15.04

August 26, 2015

KDE Plasma 5.4

The KDE Community finally announced the release of Plasma Desktop 5.4.0 yesterday morning.

Plasma 5.4 brings much improved high DPI support, a new fullscreen launcher, a new Audio Volume applet, over 1400 new icons, KRunner auto-completion and search history support.

With Plasma 5.4 the first technology preview of a Wayland session is released. On systems with free graphics drivers it is possible to run Plasma using KWin, Plasma’s Wayland compositor and X11 window manager, through kernel mode settings.

For more details, read the official announcement.

plasma-desktop

Install / Upgrade Plasma 5.4 in (K)Ubuntu 15.04/(K)Ubuntu 15.10:

KDE Plasma 5.4 now is available in Kubuntu CI PPA for both KUbuntu 15.04 and Kubuntu 15.10. To install it, open a terminal emulator from launcher and run below commands one by one:

1. Add Kubuntu CI Stable PPA:

sudo add-apt-repository ppa:kubuntu-ci/stable

kubuntu-ci-ppa

If you’ve added Kubuntu backports PPA, and it does not yet update with Plasma 5.4. You may remove it via:

sudo add-apt-repository -r ppa:kubuntu-ppa/backports

2. Update system cache and upgrade your system:

sudo apt-get update

sudo apt-get dist-upgrade

If you’re not in Kubuntu, you may run below command to install KDE:

sudo apt-get install plasma-desktop

If everything goes well, restart your computer to apply changes.

To revert back your (K)ubuntu to previous status, install ppa-purge and purge the PPA as well as downgrade installed packages:

sudo apt-get install ppa-purge && sudo ppa-purge ppa:kubuntu-ci/stable

I'm a freelance blogger who started using Ubuntu 5+ years ago and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me on Google Plus or email to ubuntuhandbook1@gmail.com

18 responses to How to Install KDE Plasma 5.4 in (K)Ubuntu 15.04

  1. After doing this (no errors), I get this in Kinfocenter:

    KDE Plasma version 5.3.2
    QT Version 5.4.1

  2. Is it possible to adjust the title of this article? Many people are adding the ppa and wondering where plasma 5.4 is

  3. You can get 5.4 from Kubuntu CI ppa (ppa:kubuntu-ci/stable). I suggest to replace backports ppa with this (instead of having both together)

    • Thanks @GT. Post updated with Kubuntu CI ppa instead since Plasma 5.4 is not made into backports PPA until now.

  4. Now it works. Just upgraded and new launcher works well.

  5. Well, I’ve done that and it doesn’t work. Still 5.3. Perhaps I should manually force 5.4 version on every KDE package in Synaptic? I’m just afraid it will screw things up.

  6. Working for me with the CI PPA
    i have the backport ppa added too so no need to remove it (for me)
    apt-get dist-upgrade updated all from 5.3 to 5.4 then

  7. I get unresolved dependencies for akregator kaddressbook kdepim-runtime kleopatra kmail knotes kontact korganizer.

    kontact is essential. any ideas? thanks

    • you may purge the ppa via ppa-purge.

      sudo apt-get install ppa-purge
      
      sudo ppa-purge ppa:kubuntu-ci/stable
    • Hello. This seems to be a dependencies problem from today. I got the same problem as I tried to upgrade from plasma 5.3 (ppa:kubuntu/backports) to 5.4. I fixed it with executing a “sudo apt-get install libkf5akonadiagentbase5 kdepimlibs-data”. Right after that was finished i don’t had entries in my desktop folder anymore. Some problem with access to bla bla. But after the next re-login all things was good. Everything works fine now.

  8. I also ran into unresolved dependencies for kdepim-runtime etc. Just removed them, did the upgrade, and reinstalled them (most settings remained intact).

  9. Anyone else problems installing digikam after enabling ci stable ppa?

    chrisvdb@tesla:~$ sudo apt-get install digikam
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    digikam : Depends: libkgeomap2 (>= 1.0~digikam4.7.0) but it is not going to be installed
    Recommends: kipi-plugins but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

  10. Does this works in Ubuntu 14.04? Last time I’ve tried something similar I ended up getting KDE 4.x and not plasma.. XD

  11. The problem with these instructions is that if you are on Ubuntu and not Kubuntu and you follow the distro-update version you will end up going into kubuntu rather then staying with ubuntu and installing KDE 5.4 you should differentiate this so some newbies dont end up going into a distro they didn’t intend to.

  12. Ever thought about how this could break the opportunity to do a proper distro-upgrade from Vivid to Wily.

    The Vivid will be reaching EOL by the end of this month. It’s just not fair endangering other peoples which such **blinki** superuser **blinkie** recommondations without beeing aware of possible consequences. There I would recommend you get yourself a testing environment like virtual-box. Do the above mentioned and tryout what happens upon a distro-upgrade to Wily Werewolf. DON’t get bitten.

    Apologize to anybody following this publication and warn them!

  13. Rodrigo Halpern January 25, 2016 at 3:22 am

    Thank you!
    just as you said, goes . . . BUT (always a but . . .)
    VLC, get kinda weird… and doesn’t resize or maximize the playback windows.
    Try purging VLC, removing everything relate to VLC, but still . . . just doesn’t seems to work around.

    Also, the other players work fine.
    suggestions???

    Got Ubuntu 15.10

  14. Umayanga Sandeepa March 31, 2016 at 2:38 am

    This error coming when try to install KDE Plasma on Ubuntu 15.10. Please help me.
    This is the error

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    plasma-desktop : Depends: kactivities but it is not going to be installed
    Depends: plasma-framework but it is not going to be installed
    Depends: plasma-workspace but it is not going to be installed
    Depends: libkf5activities5 but it is not going to be installed
    Depends: libkf5activitiesexperimentalstats1 but it is not going to be installed
    Depends: libtaskmanager5 but it is not going to be installed
    Recommends: kinfocenter but it is not going to be installed
    Recommends: kscreen but it is not going to be installed
    Recommends: kwin
    Recommends: powerdevil but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.