Audacious 4.0 Released with Qt5 UI [How to Install]

March 22, 2020 — 2 Comments

Audacious music player

Audacious audio player 4.0 was finally announced as the new stable release. Here’s how to install it in Ubuntu 16.04, Ubuntu 18.04, Ubuntu 19.10, and Ubuntu 20.04.

Audacious 4.0 switches to Qt 5 UI by default, though GTK2 is still available as a build option. New features in the release include:

  • New option to hide playlist tabs.
  • New OpenMPT-based tracker module plugin
  • New VU Meter visualization plugin
  • Added option to use a SOCKS network proxy
  • New “Next Album” and “Previous Album” commands
  • The tag editor in Qt UI can now edit multiple files at once
  • Implemented equalizer presets window for Qt UI
  • Lyrics plugin gained the ability to save and load lyrics locally
  • Blur Scope and Spectrum Analyzer visualizations ported to Qt
  • MIDI plugin soundfont selection ported to Qt
  • JACK output plugin gained some new options
  • Added option to endlessly loop PSF files
  • Some other improvements and bug-fixes.

How to Install Audacious 4.0 in Ubuntu:

Note the following packages are built with default QT5 UI. The Qt port of the Winamp-like UI is still missing some key features such the Jump to Song window.

Users of the Winamp-like UI may build with GTK2 yourself, or keep the old version.

The unofficial PPA contains the latest packages for Ubuntu 16.04, Ubuntu 18.04, Ubuntu 19.10, and Ubuntu 20.04.

1. Open terminal by either pressing Ctrl+Alt+T on keyboard or searching for ‘terminal’ from application menu. When it opens, run command to add the PPA:

sudo add-apt-repository ppa:ubuntuhandbook1/apps

Type your password (no asterisk feedback) when it prompts and hit Enter to continue.

2. Then run commands one by one in terminal to install or upgrade the audio player:

sudo apt update

sudo apt install audacious audacious-plugins

Upgrade via Software Updater may not work this time as new libaudqt5 library breaks old libaudgui5 library.

Uninstall:

You can easily remove the PPA either by going to Software & Updates utility -> Other Software tab, or by running command:

sudo add-apt-repository --remove ppa:ubuntuhandbook1/apps

To remove audacious, either use your system package manager or run command:

sudo apt remove --autoremove audacious audacious-plugins

I'm a freelance blogger who started using Ubuntu 5+ years ago and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me on Google Plus or email to ubuntuhandbook1@gmail.com

2 responses to Audacious 4.0 Released with Qt5 UI [How to Install]

  1. The new version looks fine but has a white display so I rolled back to the previous version which has a dark interface.

  2. Ji m, you kept your promise, thank you!

    Stay home, stay safe!

Leave a Reply

Text formatting is available via select HTML.

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> 

*